Error on migrating with v25

I followed the upgrade instructions from v 24 to v25. On running ‘yarn rw prisma migrate dev’ I’m seeing

I’ve tried restarting my terminal and adding --preview-feature but I’m not sure how to proceed.

system info:

Blockquote System:
OS: Windows 10 10.0.18363
Node: 14.15.4 - ~\AppData\Local\Temp\yarn–1613343480942-0.22777022970865302\node.CMD
Yarn: 1.22.5 - ~\AppData\Local\Temp\yarn–1613343480942-0.22777022970865302\yarn.CMD
Edge: Spartan (44.18362.449.0)
@redwoodjs/core: ^0.25.0 => 0.25.0

Hi @ofu997 and thanks for reporting this issue.

It’s something the team unfortunately noticed Friday evening and a patch is in the works.

A point release is forthcoming shortly.

Sorry for the inconvenience — as a workaround you can ru the yarn prisma commands directly you just need to set the preview and schema flags manually.

There should be an update from @danny snd @thedavid soon.

Hi All! Sorry you’re running into this issue @ofu997.

@dthyresson I’m actually not sure what’s going on here. It’s related to the RW Prisma CLI not showing errors. But in this case there’s likely a true error happening. Regardless, yes indeed patch is on the way!

@Tobbe have you had a chance to verify the upgrade to v0.25 if fully working on Windows?

@ofu997 you can run the prisma command directly but you’ll need to pass both --preview-feature AND --schema path. Take a look at the green output line Running the prisma cli: Directly beneath that is the full command + flags + values you should copy starting with yarn prisma ... through ...\db\schema.prisma . Then paste it into the command line and you should see the error with (hopefully) recommended steps to resolve.

Please keep us posted.


I saw the error this evening too.
Here is my setup:

  1. Running on Mac
  2. Created new app using sqlite worked as normal.
  3. Creating same app using postgresql had error. So i just updated the schema.prisma and .env files

a. Running yarn rw prisma migrate dev (failed)
b. note: cd to api folder
c. Running yarn rw prisma migrate --preview-feature --schema “xxxx” (worked)
(note: I got the actual yarn command line from the failed “rw prisma migrate dev” output)

P.S. Thank you for the workaround (setting the flags). Saved me a lot of time trying to figure it out myself.


No, not yet.

Yesterday I started going through the tutorial with v0.25 and I have been submitting PRs as I go #568 #569 #570. I’m currently on Pt I - Routing Params. I’ll continue working my way through the tutorial and once that’s done and I have a better understanding of what’s broken and in what way with a fresh v0.25 install I’ll try an upgrade and see what (if any) additional problems I run in to.


Hi all, this should now be fixed via this patch release v0.25.1

Please run yarn rw upgrade and let us know!

Is the command yarn rw upgrade meaningful only if I already have the v0.25.1 installed or do I need to take two steps, starting from my current 0.23.0 using the document Releases · redwoodjs/redwood · GitHub

RedwoodJS users that have not yet invested any efforts into application development (are still kicking tires), can forget any history of releases and simply start as advised in the tutorial here:

If this is your first time using Redwood then no worries: the latest version will be installed automatically when you create your app skeleton!

That is the approach I am taking now, as fixing the code of the few snippets I have is a lot easier than going through Upgrading to RedwoodJS v0.25 (and Prisma v2.16): DB Upgrades and Project Code Mods.

Lastly, let me mention my long-lasting pipe dream (although I created a few prototypes several years ago) of an “Intelligent CLI” (which needs to become a real desktop app, rather than using a command-line interface) that advises the user of all available upgrade options and handles user’s choices of the upgrade options.

I just verified that the command yarn rw prisma migrate dev executes correctly on windows:

>yarn rw prisma migrate dev
yarn run v1.22.5
$ C:\work\learning\redwood\redwoodblog\node_modules\.bin\rw prisma migrate dev

Running Prisma CLI:
yarn prisma migrate dev --preview-feature --schema "C:\work\learning\redwood\redwoodblog\api\db\schema.prisma" 

warn @prisma/cli has been renamed to prisma.
Please uninstall @prisma/cli: yarn remove @prisma/cli
And install prisma: yarn add prisma
Prisma schema loaded from db\schema.prisma
Datasource "DS": SQLite database "dev.db" at "file:./dev.db"

SQLite database dev.db created at file:./dev.db

√ Name of migration ... create posts
The following migration(s) have been created and applied from new schema changes:

  └─ 20210221005530_create_posts/
    └─ migration.sql

✔ Generated Prisma Client (2.16.1) to .\..\node_modules\@prisma\client in 136ms

Everything is now in sync.
Done in 34.76s.


 "devDependencies": {
    "@redwoodjs/core": "^0.25.1"

Note that I did not run yarn rw upgrade, sorry :smiley:

@Tobbe, a question for you: after running the command yarn rw prisma migrate dev (see above), I got the following error messages in the VSCode problems console:

Similar information is written for the HomePage as well.

Before creating an issue about this, can you tell me whether this is a known problem.

No, I have not seen that error before. Please write an issue and someone can look in to it. Thank you

Thanks, @Tobbe - created the issue 1829.