You must set a valid agent path to allow agent forwarding

Hi there, i am struggeling to set up the baremetal deploy method:
no matter how i set up the deploy.toml, i continue to get this error message:

You must set a valid agent path to allow agent forwarding

im am developing on a windows 11 machine, the server where i want to deploy to is a debian 11 with agentforwarding enabled.

what is strange is that i can list my identities via ssh-add -l just fine.
ssh -T git@github.com
also works just fine locally and when i am on my server via ssh.

In the windows Services app i have the “OpenSSH Authentication Agent” up and running.

can this be a redwood problem or is this probably on my side?
Any idea what i can do here?

Thanks a lot!

I quit trying to get this to work under windows - i am now deploying under wsl where ssh-agent works just fine