Yarn rw dev throwing AssertionError (Windows10)

Hi there, I try to follow RedwoodJs tutorial but somehow get stuck in yarn rw dev

E:\user\WEB PROJECT\redwoodblog>yarn rw dev
yarn run v1.19.2
$ "E:\user\WEB PROJECT\redwoodblog\node_modules\.bin\rw" dev
rw dev [app..]

Run development servers for db, api, and web.

  --help     Show help                                                 [boolean]
  --version  Show version number                                       [boolean]
  --app              [choices: "db", "api", "web"] [default: ["db","api","web"]]

AssertionError [ERR_ASSERTION]: [concurrently] no commands provided
    at module.exports (E:\user\WEB PROJECT\redwoodblog\node_modules\concurrently\src\concurrently.js:24:12)
    at module.exports (E:\user\WEB PROJECT\redwoodblog\node_modules\concurrently\index.js:21:12)
    at Object.handler (E:\user\WEB PROJECT\redwoodblog\node_modules\@redwoodjs\cli\dist\commands\dev.js:77:29)
    at Object.runCommand (E:\user\WEB PROJECT\redwoodblog\node_modules\yargs\lib\command.js:240:40)
    at Object.parseArgs [as _parseArgs] (E:\user\WEB PROJECT\redwoodblog\node_modules\yargs\yargs.js:1154:41)
    at Object.get [as argv] (E:\user\WEB PROJECT\redwoodblog\node_modules\yargs\yargs.js:1088:21)
    at Object.<anonymous> (E:\user\WEB PROJECT\redwoodblog\node_modules\@redwoodjs\cli\dist\index.js:20:162)
    at Module._compile (internal/modules/cjs/loader.js:1133:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10)
    at Module.load (internal/modules/cjs/loader.js:977:32) {
  generatedMessage: false,
  code: 'ERR_ASSERTION',
  actual: 0,
  expected: 0,
  operator: 'notStrictEqual'
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
    OS: Windows 10 10.0.18362
    Node: 12.16.3 - ~\AppData\Local\Temp\yarn--1590083269480-0.33966708487359054\node.CMD
    Yarn: 1.19.2 - ~\AppData\Local\Temp\yarn--1590083269480-0.33966708487359054\yarn.CMD
    Edge: 44.18362.449.0
    @redwoodjs/core: ^0.7.0 => 0.7.0

any idea?

I just create new redwood-app in a different directory E:\user\redwoodblog and now it works.

i’m not sure about what’s going on but maybe it related to space in path name just like this thread.

We have an issue with directories that have spaces on Windows. I think the problem is here: https://github.com/redwoodjs/redwood/blob/867c9ab97f47b68b9a09ff1087fac2a1b59f8d3a/packages/cli/src/commands/dev.js#L25

If someone has time to verify that the BASE_DIR with spaces is incorrectly formatted on Windows I would appreciate that.

1 Like

Hi @yudyananda Thanks for checking in on this! And we’ve definitely had some issues previously with Windows paths (including handling special characters and spaces). In general, it’s best practice for dev to not include spaces in paths. But we’ll also get to work to figure out what’s going on here!

@peterp I was curious so tried this on my Mac with a fresh install. I did duplicate the exact error. So something must have changes with our path handling in dev.js. I’ll look into it this morning and open up GH Issue.

1 Like

Related Issue on GitHub here:

1 Like

@yudyananda , you stated

The current redwood version is 0.25.1 - so you have some prehistoric version :smiley:. That makes the outcome cited by @thedavid really surprising to me!