Strapi getting in on the act?

Hi everyone,
Started to follow on with the new tutorials, but when I run the yarn command to create I get this:
error create-strapi-app@3.4.6: The engine “node” is incompatible with this module. Expected version “>=10.16.0 <=14.x.x”. Got “16.14.2”
error Found incompatible module.
An thoughts ?
This is on Windows 11 Pro
Cheers, Dave

Hi @daveit !

I don’t think create-strapi-app belong into the redwood tutorial, maybe it was installed as dependency not on purpose on your redwood project when you had tried Strapi, you can look at the package.json if is there, remove it and yarn install again. Also, for this type of error you can always change your node version if you already have nvm, by using nvm use 14

Hope this can help you ! :slight_smile:

1 Like

I’ve seen this before. It’s strange behavior from other packages that are globally installed. Happens with yarn create (which is a specific yarn command).

Find the command that lists the yarn globally installed packages. Delete the ones you don’t need, including that create-strapi, and try redwood again.

I think this behavior is fixed in the latest yarn v1. Updating that might help too. But not certain.


Thanks for the replies guys, and sorry for late reply.
All fixed now - I ended having to uninstall Yarn and reinstall and blow away the YARN folder inbetween: