[ "solved" ] Problem w/tutorial on fresh Monterey

I tried to create a new redwood-app - 1st one since upgrading from Catalina to Monterey (maybe this wouldn’t be an issue if I hadn’t skipped Big Sur…)

Boom !! It would not work, even tried not specifying --typescript

Lots of errors pointing to things that aren’t relevant - finding the first error in that mess –

gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.

I don’t this this should be in the Tutorial, but I also don’t want anyone to be turned away for any reason

should the installer check for python?

To Infinity ! and Beyond !!

Both upgrading to macOS Catalina and running a Software Update in Catalina may cause normal node-gyp installations to fail.


1 Like

Gyp is just the worst…

Yeppers, kinda normal process. Just google how to fix and/or use the guide linked above.

We think we can mitigate this. Will patch if we can.

1 Like

Oh for 'ff’s sake… Apple stops bundling Python with macOS Monterey 12.3

types against the wind for a few hours...


pyenv & python 3.10.0

npm i -g node-gyp

gyp ERR! System Darwin 21.4.0
gyp ERR! node -v v16.14.0
gyp ERR! node-gyp -v v9.0.0
gyp ERR! not ok"

[ . . . ]

success Installed “create-redwood-app@0.50.0” with binaries:
- create-redwood-app

[ . . . ]

Fire it up! :rocket:

– a journey of a thousand steps ends with a single step


FYI we’re pulling the dep that was requiring gyp. Next patch release.

1 Like

I added a note to the Baremetal setup docs about gyp errors.

1 Like

well that explains why it could fail and we could live !!

we don’t need no stinkin’ badges !!