Redwood base erroring

So when I create a new project it errors on yarn rw dev , still listens on the port according to the command and the command doesn’t exit, but going to http://localhost:8910/ gives connection refused

All I did was run yarn create redwood-app ./redwood-test then cd ./redwood-test and finally yarn rw dev

If I understand you correctly, yarn rw dev errors [fails] and is still listening on the port 8910 ?

That sounds odd… Like it succeeded once, and crashed thereafter - with the original one still left running in an indeterminate state…

You can execute this cmd (on Mac) to see what’s listening on what port to check to see if something is running that you don’t expect

lsof -i -P | grep -i "listen"

Very strange…

Hey @ExoPlant do you mind posting more details about your setup?

A tried-and-true troubleshooting step for errors like these is also removing the node_modules directory and the yarn.lock file and reinstalling.

Hi all, thanks for responding. @ajoslin103 I did try killing all node process, and that didn’t work, I did try rebooting as well and that didn’t work either. @dom I’m going to try removing the node_modules and yarn.lock but I doubt it’ll work. What details do you need exactly? I’ll post those when I notice the response.

Thanks again, Exo

I’ve tried that, and I have the same error.

Can you push the project to a public repo so we can pull & investigate?


To be honest, I don’t see much point in that as I haven’t touched the newly-generated files from the generator



I often find that trying to start StoryBook describes problems with more details so I can fix them

yarn rw sb

Also, one of the folks I helped last month actually wasn’t using an approved version of Node

  • node: “>=14.19 <=16.x”
  • yarn: “>=1.15”

Is 16.15.0 too high? (node)

nope – I’ll try your steps on 16.15.0

I’m on yarn 1.22.15

I notice that node-gyp failed during the creation, but it completed anyway.

This is what I see after setup and during startup (I had success, it worked)

anon23:Development ajoslin$ cd ./redwood-test
anon23:redwood-test ajoslin$ yarn rw dev
^[[1;9C(node:28940) [FST_MODULE_DEP_FASTIFY-REPLY-FROM] FastifyWarning.fastify-reply-from: fastify-reply-from has been deprecated. Use @fastify/reply-from@7.0.0 instead.
(Use `node --trace-warnings ...` to show where the warning was created)
  ✔ Generating the Prisma client...
gen | Generating TypeScript definitions and GraphQL schemas...
gen | 14 files generated
api | Building... Took 11341 ms
api | Debugger listening on ws://
api | For help, see:
api | Starting API Server...
api | Loading server config from /Users/ajoslin/Documents/Als/Development/redwood-test/api/server.config.js
api |
api | Importing Server Functions...
api | /graphql 528 ms
api | (node:29103) [FST_MODULE_DEP_FASTIFY-REPLY-FROM] FastifyWarning.fastify-reply-from: fastify-reply-from has been deprecated. Use @fastify/reply-from@7.0.0 instead.
api | (Use `node --trace-warnings ...` to show where the warning was created)
api | ...Done importing in 553 ms
api | Took 2703 ms
api | API listening on http://localhost:8911/
api | GraphQL endpoint at /graphql
api | 12:39:27 🌲 Server listening at http://[::]:8911
web | assets by path static/js/*.js 2.9 MiB
web |   asset static/js/app.bundle.js 2.85 MiB [emitted] (name: app) 1 related asset
web |   asset static/js/runtime-app.bundle.js 49.3 KiB [emitted] (name: runtime-app) 1 related asset
web |   asset static/js/src_pages_NotFoundPage_NotFoundPage_js.chunk.js 3.37 KiB [emitted] 1 related asset
web | asset 1.9 KiB [emitted] [from: public/] [copied]
web | asset favicon.png 1.7 KiB [emitted] [from: public/favicon.png] [copied]
web | asset index.html 483 bytes [emitted]
web | asset robots.txt 24 bytes [emitted] [from: public/robots.txt] [copied]
web | Entrypoint app 2.9 MiB (2.86 MiB) = static/js/runtime-app.bundle.js 49.3 KiB static/js/app.bundle.js 2.85 MiB 2 auxiliary assets
web | 863 modules
web | webpack 5.72.0 compiled successfully in 43414 ms
api | 12:39:32 🌲 incoming request POST xxx /graphql
api | 12:39:32 🐛 Extracting GraphQL Parameters
api | 12:39:32 🐛 Processing GraphQL Parameters
api | 12:39:32 🐛 Execution start
api | 12:39:32 🐛
api | Received GraphQL operation:
api |
api | 12:39:32 🐛 graphql-server GraphQL execution started: RedwoodVersion
api | 12:39:32 🐛 Execution end
api | 12:39:32 🐛 	 result:
api | 12:39:32 🐛 graphql-server GraphQL execution completed: RedwoodVersion
api | (node:29103) ExperimentalWarning: buffer.Blob is an experimental feature. This feature could change at any time
api | 12:39:32 🌲 request completed 245ms

I found one of the issues, my Powershell v1.0 exe didn’t exist, so it was trying to call that and couldn’t. I’ve fixed that and I’m about to try it again

That fixed it! Thanks @ajoslin103 and @dom for your help, and I’m happy my issue is resolved!

I’m super happy – 'cause I was super stumpt !!

I wonder why there was no obvious error that your Powershell v1.0 exe did not exist…

Congrats !!

Probably me thinking it wasn’t needed, I was debloating the system

yeah, but no obvious failure !! that’s like me deleting /bin/bash and things acting weird instead of saying error: /bin/bash not found


There was an error, but it was cryptic

yar! 'aint it always the way?

glad you got it !!!