Passing NODE_OPTIONS to `yarn rw dev`

Hey there,
I was faced by the issue that in order to use monero-javascript in redwoodjs with Nodejs 18 LTS, I have to pass the NODE_OPTIONS=--no-experimental-fetch to the node process that executes the development server.

First I tried the --fwd flag, but that did not work.
Then I tried to set the NODE_OPTIONS in the environment of the project so that echo $NODE_OPTIONS returns --no-experimental-fetch, running yarn rw dev then does not work either.

Finally I logged out NODE_OPTIONS in my api side with process.env.NODE_OPTIONS and only --enable-source-maps was set. I grep over the node_modules and find line with and it seems there is no variable to plug in further options. Adding the flag manually, i.e. changing the devHandler.js works!

It feels a little dirty, but works for now. Maybe this is helpful to someone else.

Hi @AlexRoosWork
Could you please create an issue for this?
I’d like to bring it up with the team to see how we want to handle it


An issue has now been created for this: [RFC]: Passing NODE_OPTIONS · Issue #9234 · redwoodjs/redwood · GitHub