Netlify deployment doesn't finish building for Redwood tutorial?

I’m brand new to Redwood and Netlify.

netlifystatus dot com has all green checkboxes.

I thought I followed Deployment | Learn RedwoodJS closely.

My Netlify app URL is, which loads but can’t find the DB (“Error: Network error: Response not successful: Received status code 502”).

I tried to trigger a new deployment, but it seemed to get stuck at the step yarn rw db up --no-db-client && yarn rw build, so I canceled it.

Then I triggered a new one 13 minutes ago, and this one got stuck at the same step.

Maybe I’m being too impatient, but I didn’t think deployments would take >13 minutes.

It seems like something is wrong.

Thanks for any tips.

That one failed with Build exceeded maximum allowed runtime.

So I started another deployment 3:40:42 PM ET, which also timed out:

3:41:46 PM: $ yarn rw db up --no-db-client && yarn rw build
4:10:42 PM: Build exceeded maximum allowed runtime

I see tons of Netlify community debugging articles such as these but am struggling to find my problem:

Hi @ryancwalsh Thanks so much for taking a dive into Redwood!

You, along with many others this weekend, have run into a new bug/issue with Netlify deployments. We aren’t sure what’s happening, but we are in touch with individuals at Netlify and hope to have this solved soon.

Here’s the tracking issue on GitHub for you to follow along:

@thedavid Cool, I subscribed to that issue. Thanks!

1 Like

@thedavid I’m new to this forum and am confused why “the community” supposedly marked both of my posts (Post IDs 429 and 430 and some of my replies) as spam and hid them.

I haven’t linked to anything other than what your tutorials are about (Redwood, Netlify, Prisma).

Am I doing something wrong?

I’m trying to participate only in a helpful appreciative way and not offend anyone.


@ryancwalsh Hey there! It’s all good and I will approve (and unhide) those posts momentarily. The forum software, Discourse, has a couple things going on for new users (which it calls Trust Level 1) that it watches just to make sure nothing malicious is indeed happening. It seems to have flagged similar links being used, which it sends to admins to check.

That said, thanks for asking. And you can DM me if you ever have questions about this in the future. Appreciate you diving in and taking Redwood for a spin!

1 Like

This issue has now been resolved using the Redwood Netlify Plugin. All new installations of Redwood now include the fix.

To fix the issue in an existing Redwood App, upgrade the Redwood Netlify plugin to v0.3.0 in the main package.json :

"netlify-plugin-prisma-provider": "^0.3.0"

For more details, see this comment in Issue 469.