API tests not working after upgrade

I recently upgraded all the way from v33 to v44 and now my API tests are throwing cryptic errors, even if I comment out all of the scenarios and tests and just use one single dummy test - did I miss something I need to change?

TypeError: db.$executeRawUnsafe is not a function

      at teardown (node_modules/@redwoodjs/testing/config/jest/api/jest.setup.js:90:16)
      at Object.<anonymous> (node_modules/@redwoodjs/testing/config/jest/api/jest.setup.js:185:3)

Node v16.13.2

Hi @darryl-snow! Just to confirm you followed each of the steps for upgrading your project?

If you have, something I would try is:
a) Delete your node_modules and reinstall
b) Generate prisma client again (yarn rw prisma generate)

Yeah I went through all of the release notes and followed each of the steps. Tried your suggestion but still getting the same cryptic error. I might try copying the code to a fresh new project to see if that works, or at least create a reduced test case.

Turns out this was something strangeā€¦ I created a new project, copied over my src folders and it worked!