Yarn create redwood-app error

Hello team,
I got this error when running the yarn command, it run infinitely:

It works perfectly normal 2 weeks ago.

I’m not sure, is there any breaking change with redwood-app?

@Tobbe could you confirm this issue behavior on Windows?

Windows 10 here; yarn create redwood-app --ts ./redwoodblog5 works normally for me.

1 Like

I recommend to use Git-bash or PowerShell to run node command on Windows.
@PantheRedEye By curiosity which shell do you use ?

1 Like

Ah; didn’t think about the shell. I use git-bash from VSCode terminal.

2 Likes

Thanks for stepping in here to help guys :slight_smile:
I definitely also recommend using git-bash as the shell and either MingGW (the default you get when you install git-bash using git-for-windows) or VSCode as the terminal.

But still a little strange it worked two weeks ago. @jasonforbart What version or RW was the last version where this worked? What version are you on now?

What version of Node are you running? I’ve seen squirrely results with different versions of Node 16 - currently using Node 16.16.0 here

Strangely, it seemed that certain versions of Node 16 had problems with sub-dependencies

To me it was a mystery - what had worked before was broken after no changes…