Vercel deployment "Something went wrong" -

Hello good fellows,

I’m trying to deploy on Vercel. The app is very simple as it is the 2 first chapters of the tutorial. I only have done minimal additions in css adding tailwinds and added comitizen. The models is Question instead of Blog and the Article views are PubQuestion views. Names are differents but it is the tutorial code, i’m doing this to be forced to type and not copy paste things :wink:

I have no error during the build, but the js is failing in the browser with TypeError: Cannot read properties of null (reading 'SplashPage') error. You can browse the app there : and repo is there : GitHub - growms/evo-redwood: test with redwoodjs.

Can you help please ?

In addition the JS code is obfuscated, is there a way to deploy in debug mode or somthing to be able to browse the deployed JS ?

So i just continued the tuto… and when i had to deploy to netlify i retried… and now it works… No clue about what fixed it.

Hello, i have done another project. The project is from scratch again. I scaffolded it and added zod. When deploying on Vercel i have the same error. Here the deployment : , here the repository GitHub - growms/redwood-zod: redwood setup with zod.

Hey, @growms it’s been a while since I worked with Vercel. I saw you mentioned looking for a log or more info. ‘Vercel logs’ is mentioned as a command in this post: Vercel Deployment Error - #3 by sergio

Maybe it can give more info?

1 Like

@growms perhaps the problem is that you have no route on /, and so it’s looking for the ‘splash page’ that rw dev defaults to?

1 Like

Perfect ! It was exactly that. I had no route on ‘/’. Now it’s working. The vercel logs give the exact same logs that when you are going in your vercel deployment on their website. Nothing more. So it is not really helpful.
Ty @PantheRedEye ! Do you know if it is a way to deploy the application without minimizing /obfuscte the code in order to debug this kind of thing please ? Or what would the best way to proceed ? I was pretty helpless on this

Note : i am canceling deployment as it was just for testing the Zod sharing feature.