[solved] Odd image flashes when using Google w/SupaBase?

When I’m signing in w/Google & SupaBase I get an odd image for a second…

Screen Shot 2021-05-28 at 12.17.23 PM

(the Last-Update is from the bottom of the Supabase component – images taken out of order)

Screen Shot 2021-05-28 at 12.23.45 PM

and there is an error in the console after the google login where my list of accounts is displayed

/o/oauth2/auth/oauthchooseaccount?client_id=894618133615-bfiji2s6udkg6nhne41o3sepr56gfvc6.apps.googleusercontent.com&redirect_uri=https%3A%2F%2Fscbqrtiaoyjyyqxuxzjl.supabase.co%2Fauth%2Fv1%2Fcallback&response_type=code&scope=email%20profile%20&state=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJleHAiOjE2MjIyMTg5MjcsInNpdGVfdXJsIjoiaHR0cDovL2xvY2FsaG9zdDo4OTEwIiwiaWQiOiIwMDAwMDAwMC0wMDAwLTAwMDAtMDAwMC0wMDAwMDAwMDAwMDAiLCJuZXRsaWZ5X2lkIjoiIiwiZnVuY3Rpb25faG9va3MiOm51bGwsInByb3ZpZGVyIjoiZ29vZ2xlIiwicmVmZXJyZXIiOiJodHRwOi8vbG9jYWxob3N0Ojg5MTAifQ.LD0GGA-KYX-xZyAQs3HRZwdagN8sX7rDzSz2AJ2bcT8&flowName=GeneralOAuthFlow:1 Invalid 'X-Frame-Options' header encountered when loading 'https://accounts.youtube.com/': 'ALLOW-FROM https://accounts.google.com' is not a recognized directive. The header will be ignored.

If you are using the Supabase UI widgets, you may want to ask Supabase support or make sure you have the most current packages.

1 Like

My mistake –

This turned out to be the Spinner component that I grabbed from the auth-playground – and tried to use inside of a material-ui interface

I replaced it with one I had already built for another material-ui project