Redwood v6.0.0 Upgrade Guide

It doesn’t seem like it’s fixed. The error is unchanged.

Hey @gilliard I reported a slightly different bug that was causing infinite redirects, and I bet the fix for this will fix the logout infinite redirect as well. Just wanted you to know!

1 Like

For anyone who was still experiencing issues with babel packages, I’ve released another patch. @razzeee tried it out as an RC and it seemed to solve the issues. Let me know if anyone is still experiencing the issues after this version:

1 Like

We are getting an error trying to start storybook

Broken build, fix the error above

However, I don’t actually see any error that it’s referring to

info => Serving static files from ././public at /
info => Starting manager..
WARN unable to find package.json for @babel/cli
info Addon-docs: using MDX2
info => Using implicit CSS loaders
info => Using default Webpack5 setup
Browserslist: caniuse-lite is outdated. Please run:
  npx update-browserslist-db@latest
99% end closing watch compilationWARN Force closed preview build

WARN Broken build, fix the error above.
WARN You may need to refresh the browser.

Command failed with exit code 1: yarn storybook dev --config-dir "node_modules/@redwoodjs/testing/config/storybook" --port 7910 --no-version-updates

Hey David @dmasters19,

It looks like @dom may have addressed this here: [Bug?]: CLI unable to launch storybook · Issue #9198 · redwoodjs/redwood · GitHub

with the comment to try running yarn dedupe … does that help?

1 Like

Latest version(s?) seems to have broken our data-migrate in docker. I’m still in the progress of figuring out, how it should work now.

Edit: Seems like running migrate once locally and checking in the changed package.json etc and changing my to use npx @redwoodjs/cli-data-migrate instead of rw data-migrate up

That’s right @razzeee sorry about that—I recently finished decoupling data migrate so that you could slim down your Dockerfile. data migrate is now a plugin like storybook and a standalone command so that you don’t have to bring in all Redwood’s hefty dev-time packages.

1 Like

thanks @PantheRedEye! @dmasters19 do let me know if yarn dedupe works for you, and could you share what version you’re on?

Thanks, no luck with yarn dedupe though unfortunately. On version 6.1.0

I’m still seeing babel issues with v6.2.3:

$ yarn rw lint

Oops! Something went wrong! :(

ESLint: 8.49.0

ESLint couldn't find the plugin "@babel/eslint-plugin".

Backing up to RedwoodJS v6.1.1 without changing anything else restores linting.

Hey @klobetime, sorry that this bug’s a bit persistent. One thing I noticed about your output there is that the eslint version, 8.49.0, seems a bit off or at least not what I’d expect. Could you run yarn why on that one for me?

For example here’s what I see on v6.2.3:

redwood-app % yarn why eslint
├─ @redwoodjs/eslint-config@npm:6.2.3
│  └─ eslint@npm:8.46.0 (via npm:8.46.0)
└─ @redwoodjs/eslint-plugin@npm:6.2.3
   └─ eslint@npm:8.46.0 (via npm:8.46.0)

Nice catch. I see:

$ yarn why eslint
├─ @redwoodjs/eslint-config@npm:6.3.0
│  └─ eslint@npm:8.46.0 (via npm:8.46.0)
├─ @redwoodjs/eslint-plugin@npm:6.3.0
│  └─ eslint@npm:8.46.0 (via npm:8.46.0)
└─ discovery@workspace:.
   └─ eslint@npm:8.49.0 (via npm:^8.45.0)

I changed our project package.json inclusion to be “=8.46.0” to lock the versions down to a match and was able to run yarn rw lint with no issues. So it looks like either the version mismatch or something in the newer eslint is the culprit here. To be clear, our setup worked fine in RedwoodJS v6.1.1 with eslint v8.48.0.

So back in the fold – thank you!

1 Like